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Comparo HD 

Comparo HD is Race-Keepers video data analysis suite which plays synchronized video alongside course map and 

data traces, including speed, lap number, lap time, G forces, as well as any other data streams available via OBD-

II, ECU/CAN or from Analog/Digital sensors.  

One of Comparo HD’s most powerful features is “Compare Mode” which allows you to play back the video and 

data of two laps/outings side‐by‐side to analyse where/why/how time was lost or gained. 

Comparo HD is available at no charge to HDX2 owners and users. 

 

Installing Comparo HD Software 

Comparo HD works in tandem with HDX2 on‐board systems, which 

captures and automatically synchronizes High Definition (HD) video and 

data. With Comparo HD, you can quickly identify how to improve your 

driving and decrease your lap times. 

To install Comparo HD: 

• Download and launch the Comparo HD installation file then follow the simple installation instructions. 

• Click Finish to automatically start Comparo HD. 

 

Updating Comparo HD 

When Comparo HD is launched, it attempts to make a connection to the Race-Keeper servers via the internet to 

check whether a newer version of the program is available. If you typically do not have access to the internet 

when you launch Comparo HD (a common occurrence if you only use the program at race tracks) it is 

recommended that you routinely launch Comparo HD when you are back at the workshop and have internet 

access so that this step can be achieved and so that you have access to the very latest Comparo HD updates and 

features. 

 

Menus and Main View 

After you’ve opened Comparo HD, you’ll notice that there are five dropdown menus across the top of the screen 

and a button that is labelled “Open”. 
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The dropdown menus are as follows: 

• File: This menu contains opening, closing, importing and exporting controls/features 

• Compare: This menu is for comparing laps and outings 

• Configure: In this menu you will configure how Comparo HD functions and create configuration update 

files for your HDX2 Main System Unit. 

• View: This menu enables you to switch between the standard and expanded views 

• Help: This menu contains links to instructional videos, shortcut keys, software/firmware updates  

 

Configuring HDX2 

Within the Comparo HD software you can configure your HDX2 system to automatically power on, and to 

automatically start and stop recording via the use of speed and time triggers. You can also change your video 

quality settings and camera layout. Configuring your Race‐Keeper system is a 

two‐step process: 

1. First you choose your desired configuration and save the resultant 

update file to a USB/SD. 

2. Next you insert this USB/SD into the HDX2 system and power it up. 

 

Create configuration and save to SD/USB 

• Open Comparo HD and select Configure‐>Configure Race‐Keeper 

Hardware from the dropdown menu. 

 

• Ensure “Race-Keeper HDX2” is selected as your system model and 

then modify your configuration accordingly. 

• When you have finished making changes to the way your HDX2 system operates, click Save. 
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• Insert a blank USB/SD, select the USB/SD as the desired save location and click OK to save the 

configuration file to the USB/SD. 

• On the USB/SD should now be a file called “capture.cfg” 

• If you ever wish to return your HDX2 system to its factory settings, just click on the “Defaults” button and 

then save this configuration to a USB/SD card. 

Upload configuration to system 

• Power on your HDX2 system and wait until the system is ready. 

• Insert USB/SD. 

• The orange “Transfer” LED will illuminate briefly. 

• The HDX2 system will reboot (typical duration of 45 seconds) 

• You should delete the “capture.cfg” file from the USB/SD before attempting to record a video data 

session to that media. 

 

Comparo HD Shortcut Keys 

Race‐Keeper provides a number of helpful shortcut keys. You should have received a “Comparo HD Keyboard 

Shortcuts” sticker with your HDX2 but if not, you can learn all of the keyboard shortcuts from within the Comparo 

HD software: 

How to View All Shortcut Keys 

To view a complete list of shortcut keys: 

• Select Help‐>Keyboard Shortcuts 

The keyboard shortcut is the key indicated to the left of the 

command i.e.  

• To open a new outing, press “o” on the keyboard 

• To move the video forward one (1) frame, press the 

right arrow on the keyboard. 
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Importing and Opening Track Outings 

How to Import an HDX2 Track Outing into Comparo HD 

To import a recording into Comparo HD: 

• Open Comparo HDM  

• Insert USB/SD with the recordings 

Comparo HD should recognise that you have inserted a 

USB/SD and search it for recordings. If this does not 

automatically occur or if the USB/SD was inserted before 

Comparo HD was open, just go to: 

• File->Import Outings from USB or SD 

• If more than one media is inserted, select the drive 

letter from which to import recordings 

Once the Export window is open and some recordings have been found, you can preview the video, add session 

name (i.e. Stage 2 – New Tyres), session type (ie. Rally), driver and car info to individual sessions. You can also 

add/edit details later. 

You can hold CTRL and select multiple outings to import 

You may choose to change the folder into which imported recordings are saved. You would do this by clicking on 

the “Importing to” button and by selecting/creating a different folder depending on how you wish to organise 

your recordings. 

PLEASE NOTE: In the bottom left corner of the Import screen is a checkbox asking if you wish to delete recordings 

from the USB/SD after they have been imported. Check this box if you want Comparo HD to delete the files from 

your USB/SD. If you would prefer to do this manually, leave it unchecked. 

After you have completed all of the above steps, click Import. 

Once a recording has been imported, it will appear in the Comparo HD library of outings in the Open window (see 

next section). 

 

How to Open an HDX2 Track Session 

To open an HDX2 session: 

• Use Import (see above) or copy file(s) from your USB/SD to a folder on your PC. 

• If you copy files from a USB/SD directly to a folder on your PC (i.e., you don’t use Import), you will need to 

point Comparo HD to the folder(s) in which your recording folders reside using the Scan feature. 

• Click the Open button in Comparo HD and then select Scan in the bottom left corner 
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• Browse for the folder on your computer that contains your recordings and then click OK. All sessions 

within the target folder are scanned and added to the Comparo HD library in the Open window; new 

sessions are added to the bottom of the list unless you re-order the library based on GPS Data/Time, 

then they would appear at the top. 

• Click on an HDX2 track session in the Comparo HD library and then click Open. 

PLEASE NOTE: You can open and play session(s) directly from USB/SD but we strongly recommend copying 

sessions to your PC for optimal playback. 

Four Main Areas of a Track Outing 

The main Comparo HD view layout is comprised of four (4) different and distinct sections: 

• Video, which plays dual stream HD video side by side 

• Data, which displays data traces  

• Course map, which shows the GPS derived track map 

• Session info, which shows lap info and splits 

 

 

Video 

To enter the Default Video player screen in Comparo HD press the “V” keyboard key: 

• Video/Audio playback control – Play, Pause, Volume 

• Lap number/time information 

• GPS date and time information 

• Video navigation controls – Inter-lap and intra-lap navigation sliders 
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If you double-click on one (1) of the dual video streams, then you enter Fullscreen Mode. 

 

In Fullscreen Mode, the camera layout becomes picture-in-picture. You are able to easily switch which camera is 

the main image by double clicking on the smaller picture-in-picture image. 

The video/audio playback and navigation controls remain although you do not have the intra-lap navigation 

control bar. 

You will also notice that some additional graphical displays appear in Fullscreen Mode such as the course map 

overlay shown in the above image. These are enabled/disabled from within the Gauge Manager screen.  

 

How to Add, Move and/or Remove Gauges 

Comparo HD displays animated gauge overlays that can be added or removed from the Default Video player 

screen and/or Fullscreen Mode. HDX2 creates video 

and data files independently, providing maximum 

flexibility to configuring gauge overlays and 

exported video files. 

To add or remove a Gauge: 

• Select Configure‐>Gauge Manager 

• Click the ON/OFF button to enable/disable 

gauges 

• Click on pull‐down menus to select a 

different gauge design 

• Click on to close Gauge Manager 
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To add or remove Data Overlays from Fullscreen Mode: 

• Check/Uncheck the boxes in the section titled “Fullscreen Data Overlays” 

To move a Gauge or Data Overlay on the video: 

• Left-click on the gauge, hold down the mouse button and move the gauge 

To resize a Gauge or Data Overlay on the video: 

• Hold down the SHIFT key then left-click on the gauge, hold down the mouse button and move up/down 

to resize 

How to Set the Accelerometer Gauge Orientation 

After you’ve installed your HDX2 system, we recommend setting the accelerometer gauge orientation in 

Comparo HD: 

• Select Configure‐>Gauge Manager 

• Left click on the red arrow in the accelerometer gauge 

thumbnail and rotate it to the direction in which connectors on 

the HDX2 system are pointing (i.e. if system is installed with 

connectors facing the front of the vehicle, point the red line at 

12 o’clock). 

• Click the ON/OFF button on the accelerometer gauge so that it 

appears on the video player. 

• Play some captured video and verify that: 

o During braking, the coloured dot on the vertical axis 

moves up the scale and during acceleration, the coloured dot moves down the scale 

o During left‐hand turns, the coloured dot on the horizontal axis moves to the right, and vice‐versa. 

 

How to Zero the Accelerometer on the Accel Gauge 

Even after you have zero-ed the built-in tri-axial accelerometers inside the HDX2 Main System Unit, you may 

need to zero them in Comparo HD so that, when the car is fully stationary, the coloured dot is perfectly central. To 

zero the accelerometer gauge: 

• Navigate to a point in the recording in which the vehicle is stationary and on relatively flat ground. 

• Right‐click on the accelerometer gauge in the video player 

• Click Center 
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Course Map 

To enter the Course Map screen in Comparo HD, press the “M” keyboard key. The Course Map provides: 

• Bird’s eye graphical view of the course 

• Graphical indicator of vehicle position on course 

• Corresponding data for vehicle position on course 

• Video thumbnail and playback control 

• Full navigation controls 

 

 

How to Add/Move the Start Line on the Course Map 

Comparo HD assesses GPS data for each track session and automatically assigns a start/finish line position on 

the course map. Comparo HD uses the start/finish line to establish lap number, lap times and split sectors 

(configured by the user). The start line is indicated by a blue line with an arrow, which indicates the direction of 

travel.  

 

If your recordings are from an event where the start and finish lines are located in different places (Autocross, 

Rally, Drag Race, Hill Climb) you will need to define these recordings as such in the “Session Type” section in 

Session Info. For such events, Comparo HD will assess the GPS data and automatically locate the “Launch Event” 

and “Finish Event”, positioning the start and finish lines accordingly. 
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You may want to fine‐tune or change the position of the start/finish line.  There are two ways to do so: 

To move the start/finish line on the course map: 

• Place mouse over the blue line & arrow. You should see this become thicker 

• Left-click to grab the start/finish line 

• Move the start/finish line forwards/backwards on the course map 

• Let go of the mouse button when in the correct location 

The above method may not be highly accurate so an alternative method is to set the start/finish line via the 

video: 

• Review video and/or data trace to identify exact position of start/finish line – stop the video with your 

vehicle right on the start/finish line, using the left and right arrow keyboard keys to move the video 

forwards/backwards one frame at a time. 

• When the vehicle is on top of the start/finish line, select “Configure‐>Put Start Line at Cursor Position” 

NOTE: You will find that, the first time you visit a new track, the start/finish line will automatically be placed in the 

pitlane, so your multi-lap outing will appear as a single lap. Use the above instructions to position the start/finish 

line correctly and separate your outing into the correct 

number of laps.  

If you now associate the name of the track (i.e. Silverstone 

GP) with this outing by going to “Configure->Edit Outing #1 

Info” and entering the name in the “Course Name” section, all 

other outings that share the same “Course Name” will now 

share the same start/finish line (and sector split markers – 

see below). 

How to Add/Move Splits to the Course Map 

One method to assess how well you drive on different parts of the track is to split the course map into sectors 

and then evaluate your time and video for each split segment. 

To add a split marker: 

• Place your mouse over a spot on the course map 

• Right-click on the split marker 

• Select “Insert split marker here” 

To move a split marker: 

• Place your mouse over a split marker. You should see this become thicker  

• Left-click to grab the split marker 

• Move the split marker forwards/backwards on the course map 

• Let go of the mouse button when in the correct location 
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The Data Graph on both the default combined view and the Data Graph view should now have added split sector 

segments titled S1 (Straight 1), T2 (Turn 2), etc: 

 

  

To view split times and corresponding video and data, expand the Session Info window by pressing the “i” key on 

the keyboard and then press the “Show Splits” button: see the “Session Info” section for more info on this. 

 

How to Delete Splits From the Course Map 

There are two ways to delete split markers, individually or all markers at once. 

To delete an individual split marker: 

• Expand the course map by pressing “M” on the keyboard 

• Place your mouse over a split marker 

• Right-click on the split marker 

• Select “Delete split marker” 

To delete all split markers: 

• Select “Configure‐>Delete All Section Markers” 

• Select “Yes” to confirm 

 

What the Colours Indicate on the Course Map 

When the course map is expanded by pressing “M” on the keyboard, there is a legend in the bottom‐right corner, 

which indicates the scaling of the colours that appear overlaid on the course map. 
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To change the scales of the legend: 

• Return to the default combined view by pressing “X” on the keyboard 

• Place mouse over scale of vertical axis (e.g., speed) on data graph 

• Left-click to raise/lower the dashed lines on the scale to change the values of the legend. You should see 

the course map colours change as you perform this action. 

The default data overlay that is positioned over the course map is “Speed”. To change which 

data is overlaid, you can select from the options that appear on the left of the Course Map 

window. Selecting Lateral G will provide insight into potential oversteer/understeer 

moments through corners while selecting Inline G will show you braking/acceleration points 

as well as any particularly large bumps. Vertical G can also be used to show this. When you 

have additional OBD-II or ECU/CAN data available, other information such as gear and throttle position are very 

informative when viewed in this way, especially when comparing laps with other drivers. 

 

Data Graph 

The Data Graph page in Comparo HD can be accessed by pressing “G” on the keyboard. This page provides: 

• Color‐coded data traces for valid data channels 

• Selection pane for turning valid data traces on/off 

• Vertical and Horizontal scales, with corresponding values 

• Display based on distance or time 

M  
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How to Add/Edit Data Traces 

Comparo HD automatically displays a data selection pane and all available data sources for each session. 

To add or edit data traces: 

• Review the available data traces in the data selection pane 

• Check box next to data trace(s) to toggle traces on/off 

In the expanded data graph, Comparo HD automatically displays up to three data 

trace windows corresponding to the selected data traces. 

If you right-click on any data label in the data selected pane, you have the ability to 

thicken that data trace, making it easier to see.  

There is also a button in the top right corner of the both Data Graph on the default 

combined view and the Data Graph view that will toggle the Data Graph 

background between WHITE and BLACK. 
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How to Zoom to Examine Data More Closely 

To view data more closely, Comparo HD provides the capability to zoom into the Data Graph on both the default 

combined view or the Data Graph view. 

• To zoom data you can either press “Z” on the keyboard or select “View‐>Zoom Graph” 

 

Session Info 

The Session Info page in Comparo HD can be accessed by pressing “i” on the keyboard. This page provides: 

• Information about the session 

• Number of laps and corresponding lap times 

• Split sector times 

• Fastest lap and split sector times highlighted in green 

• Target lap time calculated from all fastest split sector times 

PLEASE NOTE: In order to view split sector times, you must first create split sector markers on the course map 

and then click the “Show Splits” button. Please see “How to Add/Move Splits to the Course Map” on page 34 for 

more details on how to create split sectors. 

Clicking on any lap or split time will automatically move the video forward/backwards to that position in the 

recording. 
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How to Edit Session Info 

When in the default combined view, session info provides important info about each HDX2 recording such as: 

• Course Name  

• Driver name 

• Car 

• Date & Time 

• Session Type 

• Lap Information 

• HDX2 Firmware Version 

• Video Resolution 

• Frame Rate 

• Start on Speed Information 

• Stop on Speed Information 

• Start on USB/SD Insertion Information 

A lot of this information is created automatically based on 

your HDX2 configuration and recording details but some of 

this will need to be manually inputted by the user. 

To edit session info: 

• Select Configure‐>Edit Session #1 (or 2) info 

• Select desired options from pull‐down menu(s) or Click New to add selection options 

• Click OK when finished 

 

Using Compare Mode 

One of the most effective methods to improve your driving is to compare yourself to against the best, whether 

it’s someone else’s session or a particularly good session, lap or split of your own. Comparo HD gives you the 

power to easily compare laps and sessions on the same course. 

PLEASE NOTE: On less powerful laptops and computers, you may need to use the Picture in Picture controls to 

turn off the Camera 2 image, in order for video to play smoothly.  
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How to Compare One Lap to Another from the same outing 

To compare one lap to another from the same recorded session: 

• Select “Compare‐>Compare Laps” or press “L” on your keyboard. 

Compare mode automatically synchronizes sessions to each other upon opening. To re‐sync at any time you can: 

• Double‐click at any point on the data graph. 

• Double-click at any point on the course map. 

• Press the “Sync” button 

• Go to “Compare->Sync Sessions” 

 

How to Compare Laps from one outing with those from another outing 

To compare laps from different recordings: 

• Select “Compare‐>Compare Outings”, press “C” on your keyboard or click the “Compare” button. 

M The “Open” menu pops up with sessions available for comparison (i.e. sessions from the same course) 
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• Click on the session you want to compare 

• Click on Open 

 

When you click on “Open”, the two sessions are automatically displayed side‐by‐side. 
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How Expanded Video Window Changes in Compare Mode 

When in “Compare Mode”, Comparo HD’s video page, accessible by clicking “View->Video” or by pressing “V” on 

the keyboard, displays large screen video. This page will display any enabled gauges. 

 

By double-clicking on a video feed, you will enter “Fullscreen Mode” which will also display any enabled fullscreen 

data overlays alongside any enabled gauges. 
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How Expanded Data Graph Window Changes in Compare Mode 

When in “Compare Mode”, Comparo HD’s Data Graph page, accessible by clicking “View->Graph” or by pressing 

“G” on the keyboard, provides a clear display of the differences in data. 

 

How Expanded Session Info Window Changes in Compare Mode 

When in “Compare Mode”, Comparo HD’s Session Info page, accessible by clicking “View->Info” or by pressing “i” 

on the keyboard, displays all split sector times side by side. 
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How to Re‐sync Sessions in Compare Mode 

“Compare Mode” automatically synchronizes sessions to each other; as sessions 1 and 2 diverge due to different 

driving performance and/or course conditions, the sessions will become out of sync. 

To re‐sync sessions in “Compare Mode”: 

• Double‐click at any point on the data graph. 

• Double-click at any point on the course map. 

• Press the “Sync” button 

• Go to “Compare->Sync Sessions” 

How to Un‐Compare Sessions 

To un‐compare sessions: 

• Click on the “Compare” button and confirm action 

• Click “Compare->Uncompare Outings” 

• Press “U” on the keyboard 

 

Using Export to Create Video Files with Data Overlays 

HDX2 produces video and data files independently, which gives maximum flexibility to configuring gauge overlays 

and exported video files. After your session, you can decide exactly how you want to display data and gauge 

options or modify the layout for different presentation requirements. 

Comparo HD offers two types of edit and export functions: 

• Export a session to a video file (e.g., MPEG4) for posting to the Internet 

• Crop and save part of a session (e.g., best lap) for continued use within Comparo HD 

 

How to Export Video with Gauges 

To export video: 

• Select “File‐>Export HD” to open the Export 

window 

• Modify the camera configuration, video 

quality, background, gauge and overlay 

settings accordingly 

PLEASE NOTE: If you wish to use custom 

backgrounds, save these files to “C:\Program 

Files\Trivinci\Race-Keeper Comparo\backgrounds” 
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• Next either left-click drag the “Start” indicator (green arrow labelled Start) to where you want your 

exported video to begin OR play the video by clicking on the “Play” button and when you reach the 

required start point click on the “Start” button 

Note – You can use the keyboard arrow keys to go forwards or backwards by one frame 

• Next either left-click drag the “End” indicator (red arrow labelled End) to where you want your exported 

video to end OR play the video by clicking on the “Play” button and when you reach the required finishing 

point click on the “End” button  

Note - The estimated file size should now appear in the Video Quality dropdown menu and the expected 

length of export in MM:SS should now appear above the Export button 

• Click “Export”, navigate to desired save location, edit the file name, and click on “Save” 

 

Using Crop to Edit and Save Parts of a Track Outing 

“Crop Outing” gives you the power to edit and save specific sections of your track session and save all of the 

session’s corresponding data for additional analysis or for distribution to your instructor, teammates or 

colleagues. 

 

How to Crop and Save a Track Outing 

To crop a session: 

• Select “File‐>Crop Outing” 

• Next either left-click drag the “Start” 

indicator (green arrow labelled Start) 

to where you want your cropped 

video to begin OR play the video by 

clicking on the “Play” button and 

when you reach the required start 

point click on the “Start” button 

Note – You can use the keyboard arrow 

keys to go forwards or backwards by one 

frame 

• Next either left-click drag the “End” 

indicator (red arrow labelled End) to where you want your cropped video to end OR play the video by 

clicking on the “Play” button and when you reach the required finishing point click on the “End” button  

• Click Crop, navigate to desired save location, edit the file name, and click on “Save” 

 



 

 

  

 

Trivinci LLC  HDX2 User Guide v1.0.0 March 2015 26 

   

 

Trouble-Shooting 

PC Requirements and Compatibility 

What PC do I need to run Comparo HD? 

Playing two (2) HD video streams, synchronised together with additional data and graphics can work a PC’s 

processor and memory pretty hard. Using “Compare Mode” and having all four (4) HD video streams running 

together will work your PC even harder. As such, you should be aware of the Recommended and Minimum PC 

specifications required to successfully run Comparo HD. 

Recommended PC Specification: 

• Processor: Intel i7 Processor  

• Memory: 8GB RAM 

• Graphics: 2GB AMD Radeon or NVIDIA GeForce 

• Storage: 1TB hard drive 

• USB: USB3.0 Ports 

• SD: SD Card Port  

Minimum PC Specification: 

• Processor: Intel i5 Processor  

• Memory: 4GB RAM 

• Graphics: Built-In 

• Storage: 250GB hard drive 

• USB: USB2.0 Port 

• SD: SD Card Port 

PLEASE NOTE: If using a machine running at the minimum PC specifications, you will 

have to turn off the picture-in-picture (PiP) view when in compare mode otherwise the 

video playback will not be smooth and may freeze altogether. In order to turn off the 

PiP view, click on button “1” or “2” in the “Picture in Picture Controls”.  

 

What version of Microsoft Windows is Comparo HD compatible with? 

You can use Comparo HD on the following versions of Microsoft Windows: 

• Windows 8.1 (64) 

• Windows 8.1 (32)  

• Windows 8 (64) 

• Windows 8 (32) 

• Windows 7 (64)  

• Windows 7 (32) 
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PLEASE NOTE: We do not recommend using Comparo HD on Windows XP or Windows Vista as it is likely that 

hardware running such operating systems will not meet the “Minimum PC Specification” listed above. 

 

Can I use Comparo HD on a Macintosh or Linux Machine? 

There is no native Apple Mac or Linux version of Comparo HD however you can use a Windows 

emulator to successfully run the software, like Parallels or VMware Fusion. Either of these tools 

will allow you to run the Windows operating system as a normal “windowed” program. From 

there, you can install any normal Windows applications, including our software. If you do install 

VMware or Parallels, be sure to enable 'Hardware Accelerated 3D Graphics' in the settings for 

the virtual machine you create.  

You can also use Apple’s “Bootcamp” to install Windows on a partitioned hard drive. For more 

information on this, please visit this page https://www.apple.com/uk/support/bootcamp/  

We are working on a cross‐platform version of Comparo HD that will work perfectly as a native 

Macintosh application.  

 

What is the maximum capacity USB/SD card I can use? 

We have successfully used 32GB, 64GB or 128GB capacity USB/SD cards without issues. The HDX2 system 

should support the use of higher capacity USB/SD but these have not been tested. 

 

Opening and Scanning Outings 

Why can’t I see my outings in Comparo HD?  

If you can’t see your outings in Comparo HD, they probably have not yet been imported into the Comparo HD 

library. In order to successfully import files: 

• Ensure Comparo HD is open before you attach any USB/SD card containing HDX2 sessions. 

When Comparo HD recognises a new media device has been connected, the program will check for and repair any 

damaged files. 

• You may wish to additionally run Windows CHKDSK and check the integrity of the files on the USB/SD 

manually. If the recording media was removed from HDX2 while the system was writing to it, the end of 

the video and data files may not be complete and will need to be repaired. Windows CHKDSK will perform 

this repair. 
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Why do my outings fail sometimes when I record to USB/SD? 

Not all USB/SD cards are created equal. Some may not have the necessary write speed in order to capture HD 

video. SD cards may also have a slider on the left hand side which looks it meaning you cannot write data to it. 

With USB, it would be worth ensuring that the memory stick is properly inserted and there is no chance it could 

become detached during running.  

 

General Comparo HD Questions 

Comparo HD software appears blurry, how can I fix this? 

If you have a HD compatible display on your PC or laptop, you may 

need to adjust the way Comparo HD appears in order for the software 

to look crisp and clear. To do this: 

• Right-click on the Comparo HD shortcut on your desktop 

• Select “Properties” 

• Select the “Compatibility” tab 

• Check the box labelled “Disable display scaling on high DPI 

settings” 

• Click Apply and then OK. 

When next launched, you should see some visual improvements to 

Comparo HD. 

 

Why does my session appear as only one lap in Comparo HD? 

If the start/finish line is positioned off the main track (i.e. in the pitlane), then multiple laps will be displayed as 

just one long lap. For more information read “How to Add/Move the Start Line on the Course Map” on page 33. 

 

Does zero‐ing the accel in Comparo HD apply to one outing or to all? 

When you zero the accelerometer in an outing, this offset will be applied to all outings so there is no need to re-

zero each time you load an outing. 
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Video Player 

Why does my video look choppy? 

Playing HDX2 outings on a computer that does not meet the minimum PC specification can cause the video to 

look very choppy when playing back in Comparo HD. The problem is exacerbated when using “Compare Mode” or 

when very long continuous video files are opened. 

If your computer does meet the minimum PC specification but you are still suffering issues, it could be related to 

the computers power settings, even if your computer is plugged in and charging. 

To check your laptop power settings: 

• Left-click on the battery icon in the lower right-hand 

corner of Windows 

• Select “More Power Options” 

To check your PC power settings: 

• Open your “Control Panel” 

• Select “Power Options” 

You should now see a screen on which you can select your 

“Power Plan”. You should select the “High Performance” option.  

PLEASE NOTE: The “High Performance” option may be hidden in a section called “Show Additional Plans”. 

Once you have changed the “Power Plan” of your computer to “High Performance” Comparo HD should now play 

smoothly. 

PLEASE NOTE: When running in “High Performance” power mode, the charge in a laptop battery may be 

consumed quickly. 

 

Track Manager 

How do I find the page that shows each lap time and split? 

Access the Session Info page by selecting “View->Info” or by clicking “i” on the keyboard, and then click on “Show 

Splits” at the top of the screen. Laps are displayed down the left of the table. You can click on any of the split 

times and the video thumbnail will jump to that position on that lap. You can play the video from that position by 

hitting the space bar, stop playback by hitting space bar again.  

PLEASE NOTE: You need to create split sector markers in the Course Map before any splits will be visible. For 

more information please visit “How to Add/Move Splits to the Course Map” on page 34. 
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Is the start/finish line saved with a track? 

Once you have placed the start/finish line and split markers on a track AND provided that track a “Course Name” 

in the “Session Info”, they are saved in Comparo HD. All further outings from that track will use the same 

start/finish and split markers. There is no need to re‐enter them again. 

 

Outings List 

If I delete an outing in Comparo HD, will it be deleted from my hard drive? 

YES. Before deleting any files from within Comparo HD you need to be very sure that you no longer need it or 

have made a copy and stored it elsewhere. Once deleted, your video data file will not be recoverable. It will not 

appear in the Windows “Recycle Bin”. 

 

An outing in my library is red and labelled (missing). What do I do? 

If instead of importing HDX2 recordings you just use the “Scan” button and open them from your USB/SD, once 

you remove the USB/SD, it will appear in the library in red text with the term (missing) added to the session 

name. This is because the file is no longer located where it was when Comparo HD last accessed it. 

In order to re-associate the outing either re-attach the USB/SD or move the files to the required location. 

If you wish to remove this entry from the library, press the “Delete” button. Since the file cannot be found, all you 

are doing is deleting the entry from the list, you are not actually removing any files. 
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Cameras and Lenses 

What’s a good way to protect my cameras? 

HDX2’s HD bullet cameras produce the best image quality results when their lens covers are clean and free of 

scratches or dust. Over time, the lens covers on externally mounted cameras can degrade from the constant 

barrage of grit, dirt and sand. Clean the bullet camera lens cover, before and after every track session. We also 

recommend replacing camera lens cover after every track event to protect lenses and to prolong the life of the 

lens glass. 

The captured video is too light/dark. Can I adjust the light balance? 

HDX2’s HD bullet cameras automatically adjust to the light conditions. 

If you find that the view you are wanting to capture is over-exposed (too light), we would recommend adjusting 

the camera position and/or angle so that the camera is positioned closer to windscreen. Having two (2) cameras 

should allow you to do this, provided there is space and a suitable surface to mount the camera from.  

If you find that the view you are wanting to capture is under-exposed (too dark), adjust the camera position/angle 

so that any sources of bright light are removed.  

 

The image above illustrates an over-exposed view of the track due to the camera being located too far back in the 

cockpit and an under-exposed driver view due to a low winter sun shining through the side window. 

 



 

 

  

 

Trivinci LLC  HDX2 User Guide v1.0.0 March 2015 32 

   

 

 

 

 

 

 

 

 

 

 

 

 

 

This page is intentionally blank 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

  

 

Trivinci LLC  HDX2 User Guide v1.0.0 March 2015 33 

   

 

 

 

 

 


